Config file errors - any ideas?

Oct 25, 2011 at 5:25 PM

Hi,

I'm getting a config file error when I try to change the configuration file to look at a custom entity.

The error is "Error in Retrieve Multiple"

The XML I am using is:

  <entity name="ut_meter" displayname="Meter">
   <fetchXml>
     <fetch version="1.0" output-format="xml-platform" mapping="logical" distinct="false">
     <entity name="ut_meter">
       <attribute name="ut_name" />
       <attribute name="ut_line1" />
       <attribute name="ut_line2" />
       <attribute name="ut_line3" />
       <attribute name="ut_latitude" />
       <attribute name="ut_longitude" />
       <attribute name="ut_city" />
       <attribute name="ut_county" />
       <attribute name="ut_country" />
       <attribute name="ut_lastUsage" />
       <attribute name="ut_postalcode" />
       <attribute name="ut_stateorprovince" />
       <attribute name="ut_utilityidentifier" />
       <attribute name="ut_lastusage" />
       <order attribute="ut_name" descending="false" />
    </entity>
  </fetch>
</fetchXml>
<address>
      <latitude name="ut_latitude"></latitude>
      <longitude name="ut_longitude"></longitude>
</address>
<Conditions>
      <mapcondition text="City: ">        <condition attribute="ut_city" operator="like" value="%{0}%" />        <value type="string" default=""></value>     </mapcondition>
      <mapcondition text="Meter Name: ">        <condition attribute="ut_name" operator="like" value="%{0}%" />        <value type="string" default=""></value>      </mapcondition>
</Conditions>

<displaypanel>      <links>      </links>      <list>        <listitem text="Name">          <field name="ut_name"></field>        </listitem>        <listitem text="Last Usage">          <field name="ut_lastusage"></field>        </listitem>        <listitem text="City">          <field name="ut_city"></field>        </listitem>              <listitem text="Identifier">          <field name="ut_utilityidentifier"></field>        </listitem>      </list>      <tooltip text="Meter Pushpin">        <field name="ut_name"></field>        <color name="green"></color>        <zoomlevel name="10"></zoomlevel>      </tooltip>    </displaypanel>  </entity>

Oct 26, 2011 at 10:12 AM

Got it working. Used Advanced Find to generate the same FetchXML. Can't see what the difference is, but it worked.