Configuration tips

Jul 1, 2011 at 10:45 PM

I love the control now that it's working, but I got a little confused while getting this setup.  I added some tips in a blog post.

Thanks for building this!

Jul 7, 2011 at 9:31 AM

Hey, nice and helpful blog post. Thanks for posting it.


Sep 6, 2011 at 7:17 AM

I am using the default account and contact entities. I can get the address lookup working on the individual records but I cannot seem to get the dashboard rollup working. Even if I leave the config file alone, all I see is a white box. Right-clicking confirms it is silverlight but nothing is showing. Any tips for young players?


Leon Tribe

Sep 6, 2011 at 9:07 AM

Have you changed the bing map key. Valid key is required for bing maps to render.

Also, you are seeing this in the same dashboard which got installed with the solution provided here or you have created new dashboard?


Sep 6, 2011 at 1:18 PM

Key changed. as mentioned the individual records work fine. To try and diagnose, I spun up a 30 day online version and the dashboard worked fine. The issue appears to be on-premise. One of the developers suggested it had to do with the way the code retrieves the server name. He is going to tinker tomorrow to see if he can figure it out.

Sep 8, 2011 at 3:58 PM

Please do let me know if you found any issue in the code for On-Premise deployments.

Sep 9, 2011 at 2:26 PM

We didn't find the answer, other than it has to do with variations around whether the crm address is of the form <servername>:5555/<orgname> or <servername><orgname>. Either we see no map at all, or a map but the dropdown does not retrieve account and contact for loading. As long as we are actually on the server though it apears to be fine, which will be fine for our demo :)

Jan 9, 2012 at 12:18 AM

Has anyone been able to get this working on premise? I am having the same problem as leontribe. Any help is much appreciated.

Jan 9, 2012 at 4:45 AM

Please provide more details about your on-premise deployment configuration.

Is it SSL enabled?

Is it IFD enabled?

The client machine is joined to domain?

What different URLs have you tried?

Based on these details, I'll try in my local environment.





Jan 9, 2012 at 10:31 PM

Hi Atul,

Thanks for your reply.

I have enabled SSL 2.0 and SSL 3.0 in my local internet explorer settings.

I am not sure if it is IDF enabled..... (not sure how to tell?)

The client machine is joined to the domain. 

I have tried the following URLs;

  • http://crm2011:5555/PLANIT/main.aspx
  • http://pli2228itsg803:5555/PLANIT/WebResources/new_BingMapBrowser (Bing Maps Key is currently pointed to this address, but I have tried the other address)

Both URLs are trusted sites. I have tried enabling all options within the security and privacy settings of internet explorer.

Please let me know if there is any further info I can provide you that may help you assist me further.

Many thanks


Jan 10, 2012 at 9:21 AM

When you open http://pli2228itsg803:5555/PLANIT/WebResources/new_BingMapBrowser in IE directly, what do you get?

Please provide the screenshot by opening the Issue.

Jan 18, 2012 at 10:47 PM

Hi Atulcrm,

I opened an issue and provided a screen shot. Is there anything else I can do or provide to help you assist me with this issue?

Many thanks


Jan 19, 2012 at 7:19 PM

I've added my comments. Please take a look in the Issue.



Apr 27, 2012 at 6:20 PM

I was having the exact same issue displaying the dashboard. A map would display but no entities would load. I am using the default xml file with no configuration changes. We have an on premise deployment. When I load CRM using the URL:, only the map would display with no entities. If I use http://crm-server, the map would display with the entities loaded correctly.

It seems the isse is with wether the domain name is added to the URL. This would normally indicate IE security settings, but our domain is added to the Intranet site list in IE, and IE recognizes the FQDN URL as being on the Intranet. This means IE is applying the same security settings for either URL format so the issue seems to be somewhere else.